[Solved] Change UR5 controller keyboard settings


does anyone know how to change the keyboard settings on the UR5 controller?

The problem: keys don’t match the output. SHIFT + 0 makes an ‘=’ and it is not possible to type ‘[’ and ‘]’ which is quite annoying while programming.


Apparently there was already a solution availeble. Here is the link: (thanks Mathijs)

There are actually two ways to do this. You can change the keyboard layout with a keyboard attached to the teach pendant using a linux virtual console linux virtual console or through SSH.

Change the keyboard layout

Virtual console

Press [ctrl + alt + f1] (Might not work on all firmware versions, this didn’t work on a 1.8.x robot I used recently)
Login with username “root” and password "easybot"
Follow instructions for changing the file
Press [ctrl + alt + f7]

Connect through SSH

This is usually available on all linux systems. Under Windows you can use Putty

Change the file

nano /etc/X11/xorg.conf

There you must change the following lines:

option	"XkbLayout"	"dk"
option	"XkbVariant" 	"nodeadkeys"


option	"XkbLayout"	"us"
option	"XkbVariant" 	"altgr-intl"

press ctr + x to exit
press y to accept changes
press enter to save the file